Covering Requirements with a LabVIEW Document

NI Requirements Gateway 2018 Help

Edition Date: March 2018

Part Number: 371714F-01

»View Product Info
Download Help (Windows Only)

Complete the following steps to add to a project a downstream LabVIEW document that covers requirements in an upstream document.

Note Note  You must have a supported version of the LabVIEW development system installed to complete this tutorial. Refer to the Readme.html file for more information about supported LabVIEW versions.

Adding a LabVIEW Document to a Project

Complete the following steps to learn how to add a LabVIEW document to a project.

  1. Open <Requirements Gateway Public>\Tutorials\LabVIEWProject.rqtf.
  2. Complete the following steps to review the requirements in an upstream Specification document.
    1. In the Management view, double-click the Specification document on the Project Overview pane to launch LabVIEWSpec.txt in the default application associated with .txt files.
    2. Review the content of LabVIEWSpec.txt, which specifies the following requirements:
      • The Logic section contains a requirement that specifies the purpose of the VI.
      • The Front Panel section contains three requirements that specify controls and indicators for the front panel.
      • The Block Diagram section contains a requirement that specifies nodes of the block diagram.
    3. Exit the application that displays LabVIEWSpec.txt.
  3. In Requirements Gateway, click Edit Project on the toolbar to launch the Project pane of the Configuration dialog box.
  4. Click Add a document to add a new document on the Project Configuration pane. Place the document below the Specification document.
  5. On the Details tab, enter LabVIEW Files in the Name control and select LabVIEW from the Type of Analysis pull-down menu.
  6. Complete the following steps to specify the LabVIEW source file to use for the new document.
    1. In the File or Directory column on the Details tab, click File Browse to launch the Select Files to Include in Document dialog box.
    2. Click Add LabVIEW File and select <Requirements Gateway Public>\Tutorials\LabVIEWSignalAdder.vi.
    3. Click Open to add the file to the list of files in the Select Files to Include in Document dialog box.
    4. Click OK to close the Select Files to Include in Document dialog box.
    5. From the Variable pull-down menu on the Details tab, select Analyze Diagrams to enable this option.
  7. Click Add a cover to add a covering link. Click the LabVIEW document and then click the Specification document to create an arrow between the two documents.
  8. Click OK to close the Configuration dialog box.
  9. Click Yes when Requirements Gateway prompts you to reanalyze the project.
  10. In the Coverage Analysis view, expand the LabVIEW document in the Selection column. Requirements Gateway displays the LabVIEWSignalAdder.vi file under the LabVIEW document.
  11. Select the Specification document in the Selection column. The Downstream Coverage Information column indicates that the LabVIEW document covers 0% of the requirements in the Specification document.

    You must insert references in the source VI of the LabVIEW document to cover requirements in the Specification document.

Adding References to a LabVIEW VI

After you add the LabVIEW document, complete the following steps to insert references in the source VI of the LabVIEW document to cover requirements in the Specification document.

  1. In the Selection column of the Coverage Analysis view, expand the Specification document and the Logic section of the Specification document.
  2. Complete the following steps to insert a reference in the VI.
    1. Right-click the LABVIEW_REQ1 requirement and select Copy For»LabVIEW Text Reference to copy the covering syntax for a LabVIEW comment to cover the requirement.
    2. Double-click LabVIEWSignalAdder.vi to open this VI in LabVIEW.
    3. In LabVIEW, select File»VI Properties to launch the VI Properties dialog box.
    4. Select Documentation from the Category pull-down menu.
    5. In the VI description control, click after the existing comments and press <Ctrl-V> to paste the covering syntax from the clipboard. LabVIEW adds [Covers: LABVIEW_REQ1] to the description.
    6. Click OK to close the VI Properties dialog box.
  3. Complete the following steps to insert references to the controls, indicators, and nodes of the VI.
    1. In the Coverage Analysis view, select the LabVIEW document and click LabVIEW Tagger on the toolbar. The LabVIEW Tagger dialog box appears and lists all the requirements in LabVIEWSpec.txt.
    2. In the LabVIEW Tagger dialog box, click the LABVIEW_REQ2 requirement.
    3. In LabVIEW, click the label of the Input A control on the front panel of the VI. LabVIEW displays the Description and Tip dialog box that contains the covering syntax [Covers: LABVIEW_REQ2].
    4. Click OK to close the Description and Tip dialog box.
    5. Repeat steps b through d to insert [Covers: LABVIEW_REQ3] to the comment for the Input B control, and [Covers: LABVIEW_REQ4] to the comment for the Output indicator.
    6. Select Window»Show Block Diagram to open the block diagram of the VI.
    7. Repeat steps b through d to insert [Covers: LABVIEW_REQ5] to the comment for the Add node.
  4. Select File»Save to save the changes.
  5. In Requirements Gateway, click Yes when Requirements Gateway prompts you to reload the LabVIEW Files document.
  6. In the Coverage Analysis view, expand the LabVIEW Files document. Requirements Gateway displays the controls, indicators, and objects that contain references under the LabVIEWSignalAdder.vi file.
  7. In the Selection column, select the Specification document. The Downstream Coverage Information column now specifies that the LabVIEW document covers 100% of the requirements in the Specification document.

WAS THIS ARTICLE HELPFUL?

Not Helpful