Examples, VI Templates, Project Templates, and Sample Projects

FlexRIO Help

Edition Date: November 2015

Part Number: 372614J-01

»View Product Info

»Download the Help in ZIP Format

You can use examples, VI templates, project templates and sample projects to help build VIs and design applications.

Examples

Before you build a new VI, consider searching for an example VI that meets your needs by selecting Help»Find Examples to open the NI Example Finder. LabVIEW searches among hundreds of example VIs you can use and incorporate into VIs that you create. You can modify an example to fit an application, or you can copy and paste from one or more examples into a VI that you create. Browse or search the example VIs with the NI Example Finder by selecting Help»Find Examples

You also can access examples using the Open example and Find related examples buttons located at the bottom of certain VI and function reference topics in the LabVIEW Help. Click the Open example button to open the example VI to which the topic refers. Click the Find related examples button to open the NI Example Finder and display related example VIs.

You also can right-click a VI or function on the block diagram or on a pinned palette and select Examples from the shortcut menu to display a help topic with links to examples for that VI or function.

Refer to ni.com/support for additional example VIs. (Windows) You also can search in LabVIEW for example VIs to download from ni.com.

LabVIEW VI Templates

If you cannot find an appropriate example VI, open a template VI from the New dialog box and populate the template with built-in VIs and functions from the Functions palette. You also can use the Create Project dialog box, available by selecting File»Create Project, to browse customizable templates and sample projects.

The built-in VI templates include the subVIs, functions, structures, and front panel objects you need to get started building common measurement applications. VI templates open as [template name] #.vi, where template name is the name of the template and # is a unique decimal number. Select File»New to display the New dialog box, which lists the built-in VI templates.

Application design patterns are available in the VI»From Template»Frameworks category under Design Patterns. Application design patterns represent LabVIEW architectures and techniques that are solutions to specific problems in software design.

Creating Custom VI Templates

You can create custom template VIs to avoid adding the same components to the front panel or block diagram each time you want to perform a similar operation. Create a custom VI template by building a VI and saving it as a template.

You also can add templates as subVIs to a template VI. To add a template as a subVI, open the VI template and drag the VI icon in the upper right corner of the front panel or block diagram window to the block diagram of the top-level template VI. When you create a VI from a template that contains template subVIs and save the VI, LabVIEW prompts you to save each template subVI as a VI.

LabVIEW Project Templates and Sample Projects

LabVIEW includes several templates that provide starting points for useful design patterns, such as a state machine and a queued message handler. LabVIEW also includes sample projects that demonstrate working applications based on these templates. You can customize these templates and sample projects according to the needs of your application.

Select File»Create Project to display the Create Project dialog box, which lists these templates and sample projects.

Other Files

In the Create New list of the New dialog box, select an item from the Other Files category to create run-time menus, custom controls, global variables, and project libraries.

WAS THIS ARTICLE HELPFUL?

Not Helpful