Measurement Studio System Requirements

Measurement Studio 2012 for Visual Studio 2010 Help

Edition Date: August 2012

Part Number: 372636F-01

»View Product Info
Download Help (Windows Only)


If you want to upgrade your operating system from one major version to another, National Instruments recommends first uninstalling all National Instruments software, including application software and drivers. This is not necessary when installing an operating system service pack.

Installation Requirements

Measurement Studio 2012 includes support for Visual Studio 2010, Visual Studio 2008, and Visual Studio 2005. The following are the installation requirements for Measurement Studio 2010 support for Visual Studio 2010.

Installation Requirements for Visual Studio 2010 Support

To install and run Measurement Studio support for Visual Studio 2010, your computer must have the following:

Installation Notes

Driver Support

To use .NET class libraries that interface to National Instruments device drivers, you must install the underlying device drivers in addition to the .NET class libraries. You can run the underlying device driver installers from the NI Device Drivers DVD included with Measurement Studio or download the latest version of the NI Device Drivers by selecting NI Device Drivers from ni.com/drivers.

Note: The DAQ Assistant and the Instrument I/O Assistant are installed from the NI Device Drivers DVD. You must install the NI Device Drivers DVD to use the assistants.

Use the following table to determine what drivers are supported for each version of Visual Studio, whether the driver supports 32-bit or 64-bit applications, and the location of the installer files.

Driver Visual Studio version Bitness Installer Download Location
32-bit 64-bit
NI-DAQmx 2005 Yes No NI Device Drivers DVD
- or -
ni.com/drivers
2008 Yes Yes, available in NI-DAQmx
8.9.5 and later
2010 Yes Yes, available in NI-DAQmx
9.2.3 and later
NI-VISA 2005 Yes No NI Device Drivers DVD
- or -
ni.com/drivers
2008 Yes Yes, available in NI-VISA
4.5.1 and later
2010 Yes Yes, available in NI-VISA
5.0.3 and later
NI-488.2 2005 Yes No NI Device Drivers DVD
- or -
ni.com/drivers
2008 Yes Yes, available in NI-488.2
2.7.1 and later
2010 Yes Yes, available in NI-488.2
2.8.1 and later
NI-SCOPE 2005 Yes No ni.com/drivers
2008 Yes No
NI-IMAQ 2008 Yes No ni.com/drivers
NI-IMAQdx 2008 Yes No ni.com/drivers
NI-Vision 2008 Yes No ni.com/drivers
MAX (Measurement & Automation Explorer) 2005 Yes No NI Device Drivers DVD
- or -
ni.com/drivers
2008 Yes Yes, available in MAX 4.6
and later
2010 Yes Yes, available in MAX 4.7.2
and later
NI-DMM 2010 Yes No NI Device Drivers DVD (for underlying driver support)
- and -
ni.com/drivers (for .NET class libraries)
NI-RFSA 2010 Yes Yes NI Device Drivers DVD (for underlying driver support)
- and -
ni.com/drivers (for .NET class libraries)
NI-RFSG 2010 Yes Yes NI Device Drivers DVD (for underlying driver support)
- and -
ni.com/drivers (for .NET class libraries)

WAS THIS ARTICLE HELPFUL?

Not Helpful