メニューとツールバー



LabVIEW 2018ヘルプ


発行年月: 2018年3月
製品番号: 371361R-0112
製品情報を参照

ダウンロード (Windowsのみ)


LabVIEW 2016ヘルプ
LabVIEW 2017ヘルプ
LabVIEW 2018ヘルプ
LabVIEW 2019ヘルプ
LabVIEW 2020ヘルプ

メニューやツールバーの項目で、LabVIEWのオブジェクトの操作と変更を行うことができます。

メニュー

VIウィンドウの一番上にあるメニューには、開く保存コピー貼り付けなどの他のアプリケーションに共通の項目のほかに、LabVIEW特有の項目が含まれています。メニュー項目の中には、キーボードのショートカットの一覧を表示するものあります。

(macOS) メニューが画面の最上部に表示されます。

メモ  メニュー項目には、VIの実行中に使用できないものもあります。

ショートカットメニュー

すべてのLabVIEWオブジェクトには関連付けられたショートカットメニューがあります。これは、詳細メニュー、ポップアップメニュー、右クリックメニューとも呼ばれます。VIを作成するとき、ショートカットメニュー項目を使用して、フロントパネルおよびブロックダイアグラムオブジェクトの外観や動作を変更します。ショートカットメニューにアクセスするには、オブジェクトを右クリックします。

(macOS) <Control>キーを押しながらクリックすると、右クリックと同じ操作を実行できます。

VIを編集しているとき、制御器または表示器のショートカットメニューにはさまざまな共通オプションが含まれます。制御器または表示器のショートカットメニューの最初の2つのラインより上にあるメニュー項目は、すべての制御器と表示器に共通しています。2番目より下のメニュー項目は、オブジェクトに対してカスタマイズされています。ショートカットメニューのプラグインを作成することで、ショートカットメニューにカスタム項目を追加することができます。

複数のオブジェクトに共通の操作を同時に行うには、複数のオブジェクトを選択してショートカットメニューを使用します。ショートカットメニューから使用できるすべての操作がサポートされないオブジェクトも存在します。たとえば、数値制御器とストラクチャを選択してショートカットメニューから作成→リファレンスを選択すると、数値制御器のリファレンスだけが作成されます。

また、ランタイム時にVIに表示されるショートカットメニュー項目をカスタマイズできます。

キーボードショートカットをカスタマイズする

デフォルトのLabVIEWキーボードショートカットを変更およびカスタマイズすることができます。ツール→オプションを選択してオプションダイアログボックスを表示します。カテゴリリストからメニューショートカットを選択し、VIメニュー項目のキーボードショートカットを設定します。メニューショットカットページには、メニュー項目のデフォルトでのLabVIEWショートカットが記載されています。

メモ  LabVIEWは、淡色表示されたメニュー項目または非表示のVIツールバーのボタンのキーボードショートカットには反応しません。

VIツールバー

VIのツールバーにあるボタンを使用して、VIの実行、一時停止、中断、デバッグ、オブジェクトの整列、グループ化、等間隔配置、またフォントの設定を行うことができます。

プロジェクトエクスプローラウィンドウツールバー

標準プロジェクトビルド、およびソース管理ツールバーのボタンを使用して、LabVIEWプロジェクトの操作を実行します。ツールバーは、プロジェクトエクスプローラウィンドウの上部で使用できます。プロジェクトエクスプローラウィンドウを拡大して、すべてのツールバーを表示することもできます。

メモ  LabVIEW Unit Test Frameworkツールキットをインストールした場合のみ、Unit Test Frameworkツールバーが利用できます。

表示→ツールバーを選択する、および表示または非表示にするツールバーを選択することによって、ツールバーを表示または非表示にすることができます。ツールバー上の空白領域で右クリックして、表示または非表示にするツールバーを選択します。



この記事は役に立ちましたか。

役に立たなかった