ブロックダイアグラムオブジェクトをワイヤで接続する



LabVIEW 2018ヘルプ


発行年月: 2018年3月
製品番号: 371361R-0112
製品情報を参照

ダウンロード (Windowsのみ)


LabVIEW 2016ヘルプ
LabVIEW 2017ヘルプ
LabVIEW 2018ヘルプ
LabVIEW 2019ヘルプ
LabVIEW 2020ヘルプ

ブロックダイアグラムオブジェクト間のデータ転送はワイヤを介して行います。各ワイヤのデータソースは1つですが、そのデータを読み取る多くのVIおよび関数にこのデータソースを配線できます。これは、テキストベースのプログラミング言語で必要なパラメータを渡す場合に似ています。必要なブロックダイアグラムの端子をすべて配線する必要があります。上記の手順を行わないと、VIは壊れた状態となり、実行できません。ブロックダイアグラムノードに必要な端子を確認するには、詳細ヘルプウィンドウを表示してください。必要な端子のラベルは、詳細ヘルプウィンドウ内に太字で表示されます。

外観およびストラクチャを配線する

ワイヤの色、スタイル、太さは、データタイプによって異なります。これは、端子の色および記号が対応する制御器または表示器のデータタイプを示す方法と似ています。不良ワイヤは、中央に赤いXがある黒い破線として表示されます。ワイヤは、データタイプに互換性がない2つのオブジェクトを配線しようとした場合など、さまざまな理由で壊れます。不良ワイヤの赤いXについた矢印はデータフローの方向を示し、矢印の色はワイヤを流れるデータのデータタイプを示します。

データタイプの詳細については、「制御器および表示器のデータタイプ表」を参照してください。

ワイヤスタブは、配線ツールをVIまたは関数で移動したときに未配線の端子の隣に表示される短いワイヤです。ワイヤスタブは各端子のデータタイプを示します。端子の名前を記述するヒントラベルも表示されます。端子を配線すると、ノード上を配線ツールが移動しても、その端子のワイヤスタブは表示されません。

ワイヤセグメントは水平方向または垂直方向の1本のワイヤです。ワイヤの屈折点は2つのセグメントの結合点です。2本以上のワイヤセグメントの結合点を接点といいます。ある接点から別の接点までのセグメント、ある端子から次の接点までのセグメント、端子間に接点がない場合は端子から端子までのセグメントはすべて、1つの分岐ワイヤに含まれます。

ほとんどのワイヤは、あるノードから他のノードへの同期通信を表します。チャンネルワイヤは、非同期通信を表すワイヤです。チャンネルワイヤは、データの色が片側から反対側へフェードアウトするように色付けされています。ストラクチャを出入りする際にトンネルは作成されません。チャンネルワイヤとノード端子の接点には、フランジと呼ばれる小さなブロックが表示されます。

以下の図は、ワイヤセグメント、屈折点、接点、チャンネルワイヤ、およびフランジを示しています。

1 セグメント
2 屈折点
3 接点
4 チャンネルワイヤ
5 フランジ

オブジェクトを配線する

ブロックダイアグラムノードの端子を他のブロックダイアグラムノードの端子に手動で接続するには、配線ツールを使用します。端子上に配線ツールを移動すると、その端子が点滅します。VIまたは関数の端子上に配線ツールを移動すると、端子名を一覧表示したヒントラベルが表示されます。この端末に配線すると不良ワイヤが作成されることがあります。このVIを実行する前に不良ワイヤを修正する必要があります。

正確にワイヤの接続場所を確認するには、詳細ヘルプウィンドウを参照してください。VIまたは関数上にカーソルを移動すると、詳細ヘルプウィンドウではVIまたは関数の各端子のリストが表示されます。

メモ  詳細ヘルプウィンドウでオプションの端子と完全パスを表示ボタンをクリックし、VIまたは関数のオプション端子を表示します。

また、詳細ヘルプウィンドウを使用して、オブジェクトの端子に配線するデータのタイプを確認することもできます。VIまたは関数の端子上に配線ツールを移動すると、詳細ヘルプウィンドウの端子データタイプフィールドに、その端子で受け入れ可能なデータタイプの説明が表示されます。端子が複数のデータタイプを受け入れる場合、端子データタイプフィールドにはその端子のデフォルトデータタイプの説明が表示されます。

メモ  異なるデータタイプの2つのオブジェクトを配線する際、これらのタイプがLabVIEWで一致するよう強制変換されるほど類似している場合、LabVIEWはブロックダイアグラムノードに強制ドットを配置して、ノードに渡された値が異なる表記法に強制変換されたことを警告します。特定の強制では、強制ドットによってメモリの使用量および実行時間の増加、および結果の確度低下の原因になる場合があります。

ワイヤを曲げる

端子を配線する際にカーソルを水平方向または垂直方向に移動すると、一度だけワイヤを直角に曲げることができます。ワイヤを複数の方向に曲げるには、マウスボタンをクリックしてワイヤを固定した後、さらに新しい方向にカーソルを移動します。ワイヤを固定して新しい方向に移動する操作は繰り返し行うことができます。

ワイヤを取り消す

最後にワイヤを設定したポイントを取り消すには、<Shift>キーを押しながらブロックダイアグラム上の任意の場所をクリックします。(macOS) <Option>キーを押しながらクリックします。(Linux) 中央のマウスボタンをクリックします。すべての配線操作を中断するには、ブロックダイアグラムの任意の場所を右クリックするか、<Esc>を押します。

手動でワイヤの削除や入れ替えを行っていない2つの入力を持つ関数上でワイヤ位置をスワップするには、入力の1つをクリックしながら<Ctrl>キーを押します。

注意  ワイヤを交差させると、ブロックダイアグラムが煩雑になり、デバッグが難しくなる場合があります。

オブジェクトを自動配線する

選択したオブジェクトをブロックダイアグラムの別のオブジェクトの近くに移動すると、有効な接続を示すワイヤが一時的に描画されます。マウスボタンを放してブロックダイアグラムにオブジェクトを配置すると、ワイヤが自動的に接続されます。また、既にブロックダイアグラム上にあるオブジェクトを自動的に配線することもできます。LabVIEWでは、対応し合う端子が接続され、対応しない端子は接続されません。

位置決めツールを使用してオブジェクトを移動するときに、スペースバーを押すと自動配線の有効/無効が切り替えられます。

関数パレットからオブジェクトを選択したり、既にブロックダイアグラム上にあるオブジェクトを<Ctrl>キーを押したままドラッグしてコピーすると、デフォルトで自動配線が有効になります。位置決めツールを使用してすでにブロックダイアグラム上にあるオブジェクトを移動すると、デフォルトで自動配線は無効になります。

(macOS) <Option>キーを押します。(Linux)<Alt>キーを押します。

自動配線を無効にするには、ツール→オプションを選択して、カテゴリリストからブロックダイアグラムを選択します。

ワイヤの経路を設定する

ユーザがワイヤを配線する際、ワイヤ経路は自動的に設定されます。LabVIEWは、ブロックダイアグラム上でループやストラクチャなど既存のオブジェクトを避けて、ワイヤを配線します。また、配線が複雑にならないように、できる限り直線的にワイヤを配線します。さらに可能であれば、制御器の端子から自動的に配線されたワイヤは端子の右側から出て、表示器の端子に自動的に配線されたワイヤは端子の左側に入るように配線します。

自動的に既存ワイヤの経路を設定するには、ワイヤ上で右クリックし、ショートカットメニューからワイヤを調整を選択します。自動的にブロックダイアグラムのすべての既存ワイヤの経路設定を修正したり、すべての既存オブジェクトを並べ替えることができます。

配線を開始した後に<A>キーを押すと、一時的に自動ワイヤ経路設定機能を無効にし、配線経路を完全に手動で決定することができます。再び<A>キーを押すと、自動ワイヤ経路設定が有効になります。手動での配線が終了すると、自動ワイヤ経路設定が自動的に有効になります。配線を開始した後でも、マウスボタンを押しながら他の端子に配線したりポイントを設定してからマウスボタンを放すことで、自動ワイヤ経路設定を一時的に無効にできます。マウスボタンを放すと、自動ワイヤ経路設定が再び有効になります。

すべての新規ワイヤの自動経路設定を無効にするには、ツール→オプションを選択し、カテゴリリストからブロックダイアグラムを選択して、自動ワイヤ経路設定を有効チェックボックスをオフにします。

自動ワイヤ経路設定を無効にすると、最初に配線ツールを移動した方向によって、端子を垂直方向または水平方向に配線できます。端子のどこをクリックしても、ワイヤは端子の中心に接続されます。端子をクリックした後に、スペースキーを押すと水平方向と垂直方向が切り替わります。

自動ワイヤ経路設定が有効な場合にも、スペースキーを押して水平方向と垂直方向を切り替えることができます。LabVIEWは、新しい方向にワイヤの経路を見つけると、その方向にワイヤの方向を変更します。

ワイヤを選択する

ワイヤを選択するには、位置決めツールを使用してワイヤを1回、2回、または3回クリックします。ワイヤを1回クリックするとワイヤの1つのセグメントが選択されます。ワイヤをダブルクリックして、分岐ワイヤを選択します。3回クリックすると、ワイヤ全体が選択されます。

ワイヤにラベルを付ける

付属ラベルを使用すると、長いワイヤにラベルをつけて用途を示すことができます。ワイヤに付属ラベルを作成するには、ワイヤを右クリックしてショートカットメニューから表示項目→ラベルを選択します。ワイヤにラベルを付けると、シフトレジスタから渡されるワイヤ、そしてブロックダイアグラム全体におよぶ長いワイヤの判別に役立ちます。付属ラベルは、ワイヤに沿って自由に移動できます。付属ラベルはワイヤにロックできません。

不良ワイヤを修正する

不良ワイヤは、真中に赤いXがある黒い破線として表示されます。ワイヤは、データタイプに互換性がない2つのオブジェクトを配線しようとした場合など、さまざまな理由で壊れます。不良ワイヤ上に配線ツールを移動すると、ワイヤが壊れた理由を示すヒントラベルが表示されます。また、この情報は不良ワイヤ上に配線ツールを移動した際に詳細ヘルプウィンドウに表示されます。エラーリストウィンドウを表示するには、ワイヤを右クリックしてショートカットメニューからエラーをリストを選択します。ワイヤが壊れる理由の詳細を表示するには、ヘルプボタンをクリックします。

不良ワイヤを削除するには、位置決めツールでワイヤを3回クリックし、<Delete>キーを押します。また、ワイヤを右クリックしてショートカットメニューから分岐ワイヤを削除分岐ワイヤを作成未接続の配線を削除ワイヤを調整制御器に変更表示器に変更ソースで指標付け使用、およびソースで指標付け不使用などのショートカットメニューのオプションを選択することもできます。これらのオプションは、壊れたワイヤの原因により変わります。

不良ワイヤをすべて削除するには、編集→不良ワイヤを削除を選択するか、<Ctrl-B>キーを押します。(macOS) <Command-B>キーを押します。(Linux) <Meta-B>キーを押します。また、不良ワイヤを削除したいストラクチャまたはブロックダイアグラムの領域を選択して、<Ctrl-B>キーを押すことにより、選択した領域だけから不良ワイヤを削除することもできます。

注意  不良ワイヤをすべて削除するときは注意が必要です。ブロックダイアグラムの配線が完了していないためにワイヤが壊れているように表示される場合があります。

また、ワイヤの1つのセグメントを削除するとワイヤ全体が壊れる可能性があります。このような場合は、ワイヤセグメントを再接続して修正してください。

メモ  付属ラベルがつけられたワイヤのセグメントを削除した場合、付属ラベルは壊れたワイヤにそのまま維持されます。2つの壊れた付属ラベル付きワイヤを接続すると、ソース端子に接続されたワイヤのラベルが新しいワイヤのラベルとなります。

「データ通信方法」ホーム



この記事は役に立ちましたか。

役に立たなかった