メニューをスタティックにカスタマイズする



LabVIEW 2018ヘルプ


発行年月: 2018年3月
製品番号: 371361R-0112
製品情報を参照

ダウンロード (Windowsのみ)


LabVIEW 2016ヘルプ
LabVIEW 2017ヘルプ
LabVIEW 2018ヘルプ
LabVIEW 2019ヘルプ
LabVIEW 2020ヘルプ

以下の手順に従って、メニューを静的にカスタマイズします。

  1. 編集→ランタイムメニューを選択して、メニューエディタダイアログボックスを開きます。
  2. メニュータイププルダウンメニューからカスタムを選択します。
  3. 項目タイププルダウンメニューから、ユーザ項目を選択します。LabVIEWデフォルトメニュー項目をカスタムメニューに追加するには、アプリケーション項目を選択し、希望のLabVIEWメニュー項目を選択します。
メモ  LabVIEWデフォルトキーボードショートカットをカスタムメニューで使用する場合、対応するデフォルトメニューをカスタムメニューに追加する必要があります。ただし、オブジェクトの切り取り、コピー、貼り付け、詳細ヘルプウィンドウの表示およびロック、『LabVIEWヘルプ』の表示などのデフォルトキーボードショートカットは、デフォルトでカスタムメニューに含まれています。
  1. 項目名テキストボックスにメニュー項目名を入力します。メニュー項目の名前がプレビューフィールドと項目のタグフィールドに表示されます。タグ名を変更することで、メニュー項目に固有の識別子を割り当てることができます。ブロックダイアグラムは、タグ名を使用してメニュー項目をプログラム的に識別します。メニュー項目タグには、メニュー項目名と同じ名前を付けることができます。

    (Windows)キーボードからメニューを開くには、項目名テキストボックスで<Alt>キーと同時に押す文字の前に下線(_)を入力します。項目名が2つの下線(__)から始まる場合、LabVIEWはメニューで項目名の最初の下線を削除して表示しますが、入力されたその他の下線はすべてが含まれて表示されます。メニュー項目に下線文字が含まれ、どの文字にも下線を付けたくない場合は、この機能を使用してください。
    メモ  項目名の最初に下線を2つ入力すると、LabVIEWが<Alt>キーにショートカットキーを割り当てることを回避しますが、ショートカットテキストボックスを使用して項目名にショートカットキーを割り当てることもできます。
  2. 有効チェックボックスをオンにして、ユーザが項目を使用できるようにします。チェックボックスをオフにすると、メニュー項目はグレー表示になり、ユーザはこの項目を使用できなくなります。
  3. チェックマークチェックボックスをオンにして、メニュー項目の横にチェックマークを表示します。チェックマークは、ユーザがメニュー項目からチェックマークをオフにするまで連続実行したい場合に役に立ちます。
  4. ショートカットテキストボックスでキーボードショートカットを作成します。<Ctrl>キーを修正キーとして使用せずに、<F1>~<F24>ファンクションキーを使用できます。その他のキー以外に<Ctrl>メニューキーを使用する必要があります。(macOS) <Command>キーを使用します。(Linux) <Alt>キーを使用します。
メモ  LabVIEWは淡色表示されたメニュー項目のキーボードショートカットには反応しません。(macOS) ファンクションキーを使用したキーボードショートカットは、ファンクションキーがExposに割り当てられていない場合のみ有効です。
  1. ツールバーの青い+ボタンをクリックして、カスタムメニューに項目を追加します。赤いXボタンをクリックして項目を削除します。
  2. ファイル→保存を選択して、メニューファイルを保存します。表示されるダイアログボックスでメニューに名前を付けて、OKボタンをクリックします。VIをロードすると、カスタマイズされたメニューが自動的にロードされます。
  3. ケースストラクチャを使用して、各メニュー項目を実行します。

ツールバーの矢印ボタンをクリックする、編集メニューの階層操作オプションを使用する、またはドラッグアンドドロップすることで、メニューエディタダイアログボックスでメニュー階層を並べ替えることができます。三角記号をクリックする、または編集メニューの展開または縮小オプションを選択して、階層を展開または縮小することができます。区切り線を追加するには、項目タイププルダウンメニューから区切り線を選択します。



この記事は役に立ちましたか。

役に立たなかった